J. Marc Boden - Tools and Shit

Cisco to Fortigate Conversion

Converts cisco VLAN interface config script into Config files for Fortigate Interfaces and Routes

Cisco Interface Table File

Name VLAN ID Comment IP Address Secondary IP DHCP Relay 1 DHCP Relay 2
VL2-BL-FW-Distr 2 BL FW Distribution 192.168.11.223 255.255.255.0 N/A N/A N/A
VL10 10 192.168.11.222 255.255.255.240 N/A N/A N/A
VL11 11 192.168.11.224 255.255.255.0 N/A N/A N/A
VL15 15 192.168.11.225 255.255.255.0 N/A N/A N/A
VL20-BL-Printer 20 BL Printers 192.168.11.220 255.255.255.0 N/A N/A N/A
VL 192.168.11.220 255.255.255.0 N/A N/A N/A
edit "VL2-BL-FW-Distr"
set vdom "root"
set ip 192.168.11.223 255.255.255.0
set allowaccess ping fabric
set description "BL FW Distribution"
set device-identification enable
set role lan
set interface "fortilink"
set vlanid 2
set status down
next

edit "VL10"
set vdom "root"
set ip 192.168.11.222 255.255.255.240
set allowaccess ping fabric
set description ""
set device-identification enable
set role lan
set interface "fortilink"
set vlanid 10
set status down
next

edit "VL11"
set vdom "root"
set ip 192.168.11.224 255.255.255.0
set allowaccess ping fabric
set description ""
set device-identification enable
set role lan
set interface "fortilink"
set vlanid 11
set status down
next

edit "VL15"
set vdom "root"
set ip 192.168.11.225 255.255.255.0
set allowaccess ping fabric
set description ""
set device-identification enable
set role lan
set interface "fortilink"
set vlanid 15
set status down
next

edit "VL20-BL-Printer"
set vdom "root"
set ip 192.168.11.220 255.255.255.0
set allowaccess ping fabric
set description "BL Printers"
set device-identification enable
set role lan
set interface "fortilink"
set vlanid 20
set status down
next

edit "VL"
set vdom "root"
set ip 192.168.11.220 255.255.255.0
set allowaccess ping fabric
set description ""
set device-identification enable
set role lan
set interface "fortilink"
set vlanid
set status down
next

end
Cisco Routing Table File

Name Original IP Network Subnet Gateway
interface Vlan2 192.168.11.223 192.168.11.0 255.255.255.0 172.16.1.252
interface Vlan10 192.168.11.222 192.168.11.0 255.255.255.240 172.16.1.252
interface Vlan11 192.168.11.224 192.168.11.0 255.255.255.0 172.16.1.252
interface Vlan15 192.168.11.225 192.168.11.0 255.255.255.0 172.16.1.252
interface Vlan20 192.168.11.220 192.168.11.0 255.255.255.0 172.16.1.252
ip route 192.168.11.0 255.255.255.0 172.16.1.252
ip route 192.168.11.0 255.255.255.240 172.16.1.252
ip route 192.168.11.0 255.255.255.0 172.16.1.252
ip route 192.168.11.0 255.255.255.0 172.16.1.252
ip route 192.168.11.0 255.255.255.0 172.16.1.252
interface Vlan2
 description * BL FW Distribution *
 ip address 192.168.11.223 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp

interface Vlan10
 ip address 192.168.11.222 255.255.255.240
 shutdown

interface Vlan11
 ip address 192.168.11.224 255.255.255.0
 no ip proxy-arp

interface Vlan15
 ip address 192.168.11.225 255.255.255.0

interface Vlan20
 description * BL Printers *
 ip address 192.168.11.220 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp



Contact Me

Most of the stuff I've built requires a password to access. So link me if you want to take a peak